[Rubyinstaller-devel] Use openssl 0.9.8e in the next version?

Luis Lavena luislavena at gmail.com
Fri Dec 5 08:34:24 EST 2008

On Thu, Dec 4, 2008 at 11:03 PM, Zakaria <z4k4ri4 at gmail.com> wrote:
> On Fri, Dec 5, 2008 at 10:35 AM, Luis Lavena <luislavena at gmail.com> wrote:
>> Hmn, not that I'm aware of, you could try installing mongrel gem which
>> are signed:
>> gem install mongrel -P HighSecurity
>> That uses OpenSSL to verify the signed gem
> After doing:
> gem cert --add mongrel-public_cert.pem
> gem install mongrel -P HighSecurity
> they fail with error:
> Exception `NameError' at
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:134 -
> uninitialized constant Gem::Commands::InstallCommand
> Exception `Gem::LoadError' at
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems.rb:636 - Could not find
> RubyGem sources (> 0.0.1)

Hmn, looks like is a old version of RubyGems?

try "gem env" for provide that information to us.

> My gem is 1.3.1
> I don't know whose at fault here.

Oh, even more confused now...

RubyGems should no longer look for sources gem, it's gone since 0.9.5

>>> BTW, what is your plan for OCI? When can we expect another RC?
>> So far seems there wasn't new errors with current installer. So I'll
>> work on marking that release as Final and do the announce in
>> RubyForge.
>> I'll love to focus in the new installer to be able to deliver both
>> 1.8.6 and 1.9.1 by Christmas (or a bit after) :-D
> Looking forward for those

Me too :-)

Luis Lavena
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams

More information about the Rubyinstaller-devel mailing list