[Rubyinstaller-devel] Use openssl 0.9.8e in the next version?

Zakaria z4k4ri4 at gmail.com
Thu Dec 4 22:36:47 EST 2008

On Tue, Nov 18, 2008 at 10:14 PM, Luis Lavena <luislavena at gmail.com> wrote:
> On Tue, Nov 18, 2008 at 1:11 PM, Roger Pack <rogerpack2005 at gmail.com> wrote:
>> I wonder if there's a way to use separate versions of the dll's
>> without causing conflicts.
>> -=R

> The only way to avoid that is do static linked version of all the
> dependencies Ruby depends on (like zlib, openssl, readline and
> others).

On my windows box, I install SilkSVN and among the files they install are
SlikSvn-libeay32.dll and SlikSvn-ssleay32.dll. There are just a renamed
version of libeay32.dll and ssleay32.dll.

Maybe you could use those trick too?

> --
> Luis Lavena
> AREA 17


-- Zakaria
   z4k4ri4 at gmail.com             Yahoo!: z4k4ri4
   Mau invite gmail? japri aja.

More information about the Rubyinstaller-devel mailing list