[Rubyinstaller-devel] Ruby MinGW on Vista

Luis Lavena luislavena at gmail.com
Fri Apr 11 21:32:12 EDT 2008

On Fri, Apr 11, 2008 at 7:01 PM, David Leal <dgleal at gmail.com> wrote:
> On 4/11/08, Luis Lavena <luislavena at gmail.com> wrote:
>  >  Just run configure step by its own and peek what ended in there (of
>  >  course, on a clean sandbox and after extract and prepare).
>  I sent you an email with all the files inside ruby_build. I hope it helps.

Yes, it helped and I think I spotted where the problem lies.

Based on the files, it appears you updated the autoconf package (from
2.59 to 2.61). That is correct?

"generated by GNU Autoconf 2.61."

that is part of the config.log file.

I sticked to 2.59 since the new set of files generated by 2.61 didn't
worked properly.

config.log (2.59):


your config.log (2.61):


Somehow, dunno from where, the newer version of autoconf is being
called. The only one I see from your path that could be doing that is
Git, even more precise if you have a .bashrc file in your HOME folder
that is altering the $PATH...

Try running msys.bat from sandbox/msys and 'which autoconf' and it
should point to /bin/autoconf (7,663 bytes) and check the version
information around line 130 of that file.

Please let me know how it ended.
Luis Lavena
Multimedia systems
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams

More information about the Rubyinstaller-devel mailing list