[Rubyinstaller-devel] Building off a more recent 1.8.6 source code base?

Clifford Heath clifford.heath at gmail.com
Thu Sep 27 22:24:20 EDT 2007

Damn, I have VS2003... don't know if I can lay hands on VC++ 6.
Did MS make it available freely? However what you say means I
don't have the option of rebuilding just Ruby, because I need to
work with existing extensions.

It might be time soon to update to a more recent version and just
break compatibility with older extensions... I guess that's a big
change though.

Otherwise, any chance you could ship me a version without ODBC
working? I need to run RMagick and Gtk on about 5 target machines,
so it wouldn't get wide distribution.

Clifford Heath.

On 28/09/2007, at 11:46 AM, Curt Hibbs wrote:
> I am currently working on Release 26 which uses Ruby p110. I could  
> use some help, as my available time is limited, if you wanted to  
> pitch in. I'm actually pretty close to finished except that I'm  
> having trouble getting the Ruby ODBC to compile.
> If you checkout the installer from RubyForge (instructions are  
> here: http://rubyforge.org/scm/?group_id=167), the complete build  
> instructions are in the ReadMe.html file (you want to check out  
> from "/trunk/installer-win2"), but you have to use either VC++ 6.0  
> SP5 or MinGW (newer versions of VC++ have binary compatibility  
> problems).

More information about the Rubyinstaller-devel mailing list