[Rubyinstaller-devel] Building off a more recent 1.8.6 source code base?

Clifford Heath clifford.heath at gmail.com
Thu Sep 27 20:24:47 EDT 2007


Folk,

I'm using the current one-click installer on Windows XP, and ruby -v  
claims
to be patch-level -p0. This version has totally broken thread  
synchronisation
primitives, and that leaves me dead in the water. Sylvain Joyeux told me
in ruby-talk that p36 and p110 are much better, so...

I can either build a current Ruby from source, or build the whole one- 
click
installer from source. I have MSVC and I'm quite familiar with  
building on
Windows...

What's the ramp-up time to learn to build the one-click installer  
from source?

How hard is it likely to be to adapt the build process to the current  
Ruby source
code for 1.8.6? (Easy, I expect).

What else do I need installed - are you using WiX or something else?

Clifford Heath


More information about the Rubyinstaller-devel mailing list