[Rubyinstaller-devel] ruby-opengl update

Luis Lavena luislavena at gmail.com
Mon Oct 29 16:34:32 EDT 2007

On 10/23/07, Luis Lavena <luislavena at gmail.com> wrote:
> On 10/23/07, Jan Dvorak <jan.dvorak at kraxnet.cz> wrote:
> > Hello,
> >
> > can you please update ruby-opengl for the next OCI release ? I've created
> > package with the binaries and samples for version 0.50.0, and patch against
> > current svn of rubyinstaller is attached to this mail.
> >
> > From usage and API point of view the 0.50.0 release should be 100% backwards
> > compatible with the original Yoshi's 0.2x/0.3x bindings, the only difference
> > is that 0.2x installs files 'opengl.so' and 'glut.so', while we
> > use 'gl.so', 'glu.so', 'glut.so' and also 'opengl.rb' for backwards
> > compatibility.
> >
> Thank you Jan
> I'll review this tomorrow morning and post here the results.

Jan, sorry the delay on answering you.

It seems the binary files you provide from the ruby-opengl site
bundled in the zip listed in the patch are broken (is not a valid
Win32 image).

Maybe those are the linux ones? (found the ELF header instead of the WinPE one).

Let me know so we could ship another RC after this.

Luis Lavena
Multimedia systems
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi

More information about the Rubyinstaller-devel mailing list