[Rubyinstaller-devel] RE: [Rubyinstaller-users] Patch for installer version 13

Curt Hibbs curt at hibbs.com
Wed May 26 22:50:22 EDT 2004


Jos Backus wrote:
>
> I just checked in my installer updates. It is now possible to
> build a Ruby CVS
> snapshot located in c:/src/ruby. I had to comment out OpenGL as it makes
> builder.rb die with an EACCESS error.
>
> Please review :-)

Great!

Can someone else on the team give Jos' stuff a try -- I super overloaded. If
I can squeeze it in tomorrow it'll be ok, otherwise I won't be able to look
at it for at least a week.

> However, for some reason TortoiseCVS refuses to commit the devel
> subdirectory,
> saying nothing has changed. Doing a CVS add from Explorer tells me the
> files/directories are already part of the repository (which they
> are obviously
> not). Any ideas what I could be doing wrong? Surely it's me, not the
> software...

I just created an empty "devel" under the "install" directory and used
TortoiseCVS to do a "CVS Add..." on it -- worked just fine. So there is now
an empty devel directory in the repository.

Something must be confusing CVS. Maybe you have some "CVS" directories in
you "devel" tree?

Try saving off your devel tree somewhere, then do a CVS Update on the
"install" dir to get the "devel dir I just added. And then copy contents of
your devel tree into the new devel dir created by the update. Make sure your
devel tree does not have any CVS dirs in it (except for "devel" itself,
which should have one from the update). Then try "CVS Add..." the new
contents  of the devel tree.

Hopefully that will work. If not, zip it up and post it somewhere and I'll
get it added.

Curt



More information about the Rubyinstaller-devel mailing list