[Rubyinstaller-devel] Ruby Installer is Ready for Enhancements & Bug Fixes

Shashank Date sdate at everestkc.net
Sun Mar 28 18:34:34 EST 2004


Hi Curt,

I am trying this using VC++6.0 SP5

>   NOTE: When Expat is installed, it will popup a Windows
>         installer dialog. Unfortunately, there is no way
>         to avoid this. Just accept all of the defaults and
>         let the build continue.

When it comes to installing expat I get:
--------------------------------------------------------------------

Checking 'Expat-1.95.5'
HINT: destination directory is C:\installer\stable/Expat-1.95.5
expat_win32bin_1_95_5.exe
cd Expat-1.95.5
c:/ruby/lib/ruby/1.8/fileutils.rb:98:in `chdir': No such file or directory -
Expat-1.95.5 (Errno::ENOENT)
        from c:/ruby/lib/ruby/1.8/fileutils.rb:98:in `cd'
        from ./commands.rb:185:in `run'
        from ./commands.rb:168:in `each'
        from ./commands.rb:168:in `run'
        from ./package.rb:126:in `initialize'
        from builder.rb:185:in `new'
        from builder.rb:185
NMAKE : fatal error U1077: 'ruby.exe' : return code '0x1'
Stop.

C:\installer\builder>
-----------------------------------------------------------------------

I tried installing expat under <c:\> and then <c:\installer\stable> and
finally <c:\installer\builder>. But I get the same error in all the 3 cases.

Should I be trying some other dir? Please help.
Thanks,
-- Shashank




More information about the Rubyinstaller-devel mailing list