[Rubyinstaller-devel] [Fwd: RE: win32ole.so?]

Curt Hibbs curt at hibbs.com
Fri Jun 11 23:55:33 EDT 2004

Thanks, I was not aware.

We should probably create a "Known Problems" page on the wiki and post this
as a known problem and workaround. I can try to do this, but I'm really
snowed under, so if someone else could do it that would be great!

  -----Original Message-----
  From: rubyinstaller-devel-bounces at rubyforge.org
[mailto:rubyinstaller-devel-bounces at rubyforge.org]On Behalf Of Chris Morris
  Sent: Friday, June 11, 2004 1:52 PM
  To: Ruby Installer List
  Subject: [Rubyinstaller-devel] [Fwd: RE: win32ole.so?]

  Got this, dunno if y'all are already awares...

  -------- Original Message -------- Subject:  RE: win32ole.so?
        Date:  Fri, 11 Jun 2004 10:31:31 -0700
        From:  Chin, Wayne <Wayne.Chin at netapp.com>
        To:  <chrismo at clabs.org>

  Thanks, Chris, for responding.

  Last night, I found a workaround that works for me. I thought I'd share it
with you.

  First, here's my problem: I use win32ole.so from Ruby to manage Excel
worksheets. To my horror, the version of win32ole.so included in the distro
from rubyforge.org causes a segfault. My scripts used to run fine with other

  Here's my workaround: I overwrote my installation of Ruby from
rubyforge.org with "ruby-1.8.2-20040519-i386-mswin32.zip" from
http://ring.maffin.ad.jp/archives/lang/ruby/binaries/mswin32/. That
distribution includes a "win32ole.so" that works. Now all's well.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rubyinstaller-devel/attachments/20040611/13318edd/attachment.htm

More information about the Rubyinstaller-devel mailing list