[Rubyinstaller-devel] Include OpenSSL?

Curt Hibbs curt at hibbs.com
Fri Jul 30 08:45:50 EDT 2004

Jos Backus wrote:
> On Thu, Jul 29, 2004 at 07:02:48PM -0500, Curt Hibbs wrote:
> >
> > Rich Kilmer and Chad Fowler are busy creating a GUI interface
> for RubyGems
> > which I want to include in the installer (and possibly
> automatically invoke)
> > to allow the user to install additional packages of their
> choice. Rich has
> > promised me to have this ready within the next week or so.
> Cool.
> > If someone (you?) could package up OpenSSL as a gem, then it
> could be easily
> > installed by any user who wanted it (and we don't have to worry
> about any
> > legal issues).
> Okay, I'll look into this. Does the gem format support binary
> files (DLLs)?  I
> haven't looked into RubyGems yet, sorry. Time to do some reading.

It *does* support binary gems, but improved support is coming very soon.
Right now you can package up a binary gem for each platform, but the user
has to choose the correct version. Rich and Chad are also working to extend
it so that you just pick what package you want, and RubyGems will choose the
correct binary package for your platform.


More information about the Rubyinstaller-devel mailing list