[Rubyinstaller-devel] RubyInstaller Build -- didn't get very far

Curt Hibbs curt at hibbs.com
Sun Feb 1 23:46:51 EST 2004


Hi Guys!

I didn't get very far with trying to build the installer this weekend (due
to lack of time). I'm hoping to work on it tomorrow (Monday) night after
work. But just in case one of you has already run into the problem I got and
already know the fix I've pasted my build log below.

Please note that I have not had time to investigate this, so this could
easily be something small and obvious -- meaning, if you don't recognize
this right off, don't waste any of your time. On the other hand, if you've
run into this and you know what to do, please let me know as it will save me
some time tomorrow night.

If I don't have cygwin\bin on my path I get the results in build-log-1 which
downloads the ruby source bur fails on the tar command (because cygwin\bin
is not on the path).

If I put cygwin\bin on the path it doesn't even get to the point of
downloading the ruby source.

Am I supposed to be running this within a cygwin command prompt instead of a
normal command window?

Thanks,
Curt

=== Start Build Log 1
=============================================================

E:\Dev\RubyDev\rubyinstaller\cvs-repo\installer\builder>nmake -f makefile

Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

        ruby.exe -w builder.rb stable


***********************************************************

 Building Version 181-11

***********************************************************
--------
Ruby
--------

Downloading ruby-1.8.1.tar.gz from www.ruby-doc.org
Checking 'ruby-1.8.1'
tar -xzf ruby-1.8.1.tar.gz
        (error ignored)
cd ruby-1.8.1
./commands.rb:185:in `chdir': No such file or directory - ruby-1.8.1
(Errno::ENO
ENT)
        from ./commands.rb:185:in `run'
        from ./commands.rb:168:in `each'
        from ./commands.rb:168:in `run'
        from ./package.rb:126:in `initialize'
        from builder.rb:116:in `new'
        from builder.rb:116
NMAKE : fatal error U1077: 'ruby.exe' : return code '0x1'
Stop.

E:\Dev\RubyDev\rubyinstaller\cvs-repo\installer\builder>

=== Start Build Log 2
=============================================================


E:\Dev\RubyDev\rubyinstaller\cvs-repo\installer\builder>nmake -f makefile

Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

        ruby.exe -w builder.rb stable
./package.rb:12:in `initialize': No such file or directory -
\cygdrive\e\Dev\Rub
yDev\rubyinstaller\cvs-repo\installer\stable/versions.txt (Errno::ENOENT)
        from ./package.rb:12:in `new'
        from ./package.rb:12
        from builder.rb:36:in `require'
        from builder.rb:36
NMAKE : fatal error U1077: 'ruby.exe' : return code '0x1'
Stop.

E:\Dev\RubyDev\rubyinstaller\cvs-repo\installer\builder>



More information about the Rubyinstaller-devel mailing list