[ rubygems-Bugs-27169 ] unable to resolve transitive dependencies?

noreply at rubyforge.org noreply at rubyforge.org
Tue Jan 17 13:39:04 EST 2012


Bugs item #27169, was opened at 2009-09-23 18:53
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27169&group_id=126

Category: `gem install` command
Group: None
Status: Closed
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: unable to resolve transitive dependencies?

Initial Comment:
Appears that if you have a gem on github which depends on gems from rubyforge, which gems from rubyforge also have dependencies on gems from rubyforge, the install fails.

Ex: (a fresh install of ruby)
$ gem install rogerdpack-desc_method -v0.1.5

ERROR: Error installing rogerdpack-desc_method:
ruby2ruby requires ruby_parser (~> 2.0, runtime)

Thanks.
-r

[1] http://osdir.com/ml/ruby-talk/2009-08/msg00955.html

----------------------------------------------------------------------

>Comment By: Roger Pack (rogerdpack)
Date: 2012-01-17 18:39

Message:
refiled this at https://github.com/rubygems/rubygems/issues/96

----------------------------------------------------------------------

Comment By: Roger Pack (rogerdpack)
Date: 2010-01-19 04:38

Message:
I believe this is a duplicate of
http://rubyforge.org/tracker/?
func=detail&atid=575&aid=27608&group_id=126

(now fixed)
Thanks.
-r

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2009-09-23 18:55

Message:
That is a known issue: there is no cross repository gem dependency resolution.

Patches are welcome.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27169&group_id=126


More information about the RubyGems-Developers mailing list