[ rubygems-Bugs-29420 ] I distribute my ruby script using Ocra but when executing my exe file i get this errors

noreply at rubyforge.org noreply at rubyforge.org
Wed Nov 9 06:22:39 EST 2011


Bugs item #29420, was opened at 2011-11-09 00:33
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29420&group_id=126

Category: None
Group: v0.9.2
>Status: Closed
>Resolution: Rejected
Priority: 3
Submitted By: Khalid MOBARKI (ktemax)
Assigned to: Nobody (None)
Summary: I distribute my ruby script using Ocra but when executing my exe file i get this errors

Initial Comment:
C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in `to_spec
s': Could not find hoe (>= 1.3.0) amongst [commonwatir-2.0.2, ffi-1.0.9-x86-ming
w32, firewatir-1.9.4, nokogiri-1.5.0-x86-mingw32, ocra-1.3.0, rautomation-0.6.3,
 s4t-utils-1.0.4, safariwatir-0.3.8, user-choices-1.1.6.1, watir-2.0.2, win32-ap
i-1.4.8, win32-process-0.6.5, windows-api-0.3.0, windows-pr-1.2.1, xml-simple-1.
1.0] (Gem::LoadError)
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:761:in `block in activate_dependencies'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:758:in `each'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:758:in `activate_dependencies'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:742:in `activate'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:764:in `block in activate_dependencies'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:758:in `each'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:758:in `activate_dependencies'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:742:in `activate'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:764:in `block in activate_dependencies'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:758:in `each'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:758:in `activate_dependencies'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb
:742:in `activate'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems.rb:209:in `rescu
e in try_activate'
        from C:/Tmp/ocr77.tmp/lib/ruby/site_ruby/1.9.1/rubygems.rb:206:in `try_a
ctivate'
        from <internal:gem_prelude>:218:in `try_activate'
        from <internal:lib/rubygems/custom_require>:32:in `rescue in require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from C:/Tmp/ocr77.tmp/src/hello.rb:3:in `<main>'

----------------------------------------------------------------------

Comment By: Ryan Davis (zenspider)
Date: 2011-11-09 03:22

Message:
I'm closing this ticket as we've moved to github issues for all 
issue tracking. Please refile this ticket there if you think it is 
still valid.

https://github.com/rubygems/rubygems/issues

Thanks,

The RubyGems Team

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29420&group_id=126


More information about the RubyGems-Developers mailing list