[ rubygems-Bugs-29316 ] ruby_code case not handled: Regexp

noreply at rubyforge.org noreply at rubyforge.org
Wed Nov 9 06:22:38 EST 2011


Bugs item #29316, was opened at 2011-07-13 10:54
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29316&group_id=126

Category: `gem install` command
Group: None
>Status: Closed
>Resolution: Rejected
Priority: 3
Submitted By: Gonzalo Garramuno (gga)
Assigned to: Nobody (None)
Summary: ruby_code case not handled: Regexp

Initial Comment:
ERROR:  While executing gem ... (Gem::Exception)
    ruby_code case not handled: Regexp

When installing the ifmapper gem in rubygems.org in ubuntu's ruby-1.9.1-full.
Trying to build the gem with the same gem1.9 (-v 1.8.5), I obtain a gem that when installed reports:
ERROR:  While executing gem ... (Gem::Package::FormatError)
    corrupt gem (Gem::Package::TarInvalidError: tar is corrupt, name contains null byte) in /media/Linux/src/bin/ifmapper/ifmapper-1.1.4/ifmapper-1.1.4.gem



----------------------------------------------------------------------

Comment By: Ryan Davis (zenspider)
Date: 2011-11-09 03:22

Message:
I'm closing this ticket as we've moved to github issues for all 
issue tracking. Please refile this ticket there if you think it is 
still valid.

https://github.com/rubygems/rubygems/issues

Thanks,

The RubyGems Team

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2011-07-13 11:18

Message:
Hello,

Please report this to GitHub, the tracker is not even linked on RubyForge page anymore.


----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2011-07-13 11:17

Message:
Hi!

Believe it or not, we're moving to github's issue tracker! The 
pressure to move has been loud and clear, but for the longest time 
it didn't support the way we worked. Now that it has freeform 
labels it can support our workflow adequately. There is just one 
problem: Your bug is here and we don't want to lose you!

What we'd like you to do is fairly painless and should only take a 
few minutes:

Please file the _exact_ same ticket on github and provide a link 
back to this crufty old ticket so we can refer to any previous 
discussion that occurred. Once the new ticket is made, put a 
forwarding link to it here and close this ticket out. In a couple 
weeks, we'll track down the old tickets that are still open and 
decide what to do with them.

We could have done this fairly automatically, but we really want 
you to do it so you're attached to the ticket and we can still 
communicate with you and keep a record of it.

https://github.com/rubygems/rubygems/issues

Thanks,

The RubyGems Team

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29316&group_id=126


More information about the RubyGems-Developers mailing list