[Rubygems-developers] [ rubygems-Bugs-29080 ] rubygems-update now depends on a new version of hoe redering it useless

noreply at rubyforge.org noreply at rubyforge.org
Mon Mar 14 17:16:08 EDT 2011


Bugs item #29080, was opened at 2011-03-14 07:50
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29080&group_id=126

Category: None
Group: None
Status: Closed
Resolution: Rejected
Priority: 3
Submitted By: J. Pablo Ferández (pupeno)
Assigned to: Nobody (None)
Summary: rubygems-update now depends on a new version of hoe redering it useless

Initial Comment:
I normally user rubygems-update to update gems in Debian installations, but now that's no longer possible, it depends on hoe >= 2.8.0:

~# /var/lib/gems/1.8/bin/update_rubygems
/usr/lib/ruby/1.8/rubygems.rb:578:in `report_activate_error': Could not find RubyGem hoe (>= 2.8.0) (Gem::LoadError)

which depends on RubyGems >= 1.2.1

:~# gem install hoe --version=2.8.0
ERROR:  Error installing hoe:
	hoe requires RubyGems version >= 1.3.1

which isn't what Debian comes with:

~# gem --version
1.2.0

That made rubygems-update useless for me :(



----------------------------------------------------------------------

>Comment By: Ryan Davis (zenspider)
Date: 2011-03-14 14:16

Message:
rubygems-update is the gem we install and run when you do update --system. So if update --system doesn't work, there is a good chance that rubygems-update doesn't work.

Rubygems 1.2.0 was the first version to ship with development dependency support. So the fact that you're seeing this problem hints that you're not actually running 1.2.0 (or that debian REALLY broke 1.2.0).

As stated in UPGRADING.rdoc:

=== From rubygems 1-1.x through 1.2.x:

RubyGems 1.1 and 1.2 have problems upgrading when there is no
rubygems-update installed. You will need to use the following
instructions if you see "Nothing to update".

Use the Manual Upgrade Recipe below.
...

=== Manual Install

If you don't have any RubyGems install, there is still the pre-gem
approach to getting software, doing it manually:

Use sudo/su as appropriate:

* Download from: https://rubygems.org/pages/download
* Unpack into a directory and cd there
* Install with: ruby setup.rb


----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2011-03-14 08:54

Message:
Update first to something like 1.3.1 and *then* update to latest.

You're missing lot of steps. You didn't mention which version of RubyGems you have, but if you get >= 1.3.1 warnings means is quite old.

That means you haven't been updating RubyGems in long time, so wonder how things worked like a charm... since you didn't update them in long time.

----------------------------------------------------------------------

Comment By: J. Pablo Ferández (pupeno)
Date: 2011-03-14 08:50

Message:
Up until today, we updated all our debian servers with rubygems-update and 
everything worked like a charm. What's rubygems-update for then?

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2011-03-14 08:48

Message:
No, if you installed rubygems via debian, there is no workaround to get that working.

You have a really old version of RubyGems that can't distinguish between runtime and development dependencies.

Because of that, you need to manually install RubyGems *if* you installed manually before.

If not, you will bork your system because debian customized a series of commands.


----------------------------------------------------------------------

Comment By: J. Pablo Ferández (pupeno)
Date: 2011-03-14 08:44

Message:
I'm not doing gem update --system, I'm using rubygems-update, which was 
created specifically to workaround issues like this, wasn't it?

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2011-03-14 08:42

Message:
If you're in debian, you should follow the debian-way to update packages, not using gem update --system, which was intentionally disabled by them

Now, you can: wait for them to update it, or do it yourself.

https://github.com/rubygems/rubygems/blob/master/UPGRADING.rdoc


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29080&group_id=126


More information about the Rubygems-developers mailing list