[Rubygems-developers] [ rubygems-Bugs-29080 ] rubygems-update now depends on a new version of hoe redering it useless

noreply at rubyforge.org noreply at rubyforge.org
Mon Mar 14 10:50:13 EDT 2011


Bugs item #29080, was opened at 2011-03-14 14:50
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29080&group_id=126

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: J. Pablo Ferández (pupeno)
Assigned to: Nobody (None)
Summary: rubygems-update now depends on a new version of hoe redering it useless

Initial Comment:
I normally user rubygems-update to update gems in Debian installations, but now that's no longer possible, it depends on hoe >= 2.8.0:

~# /var/lib/gems/1.8/bin/update_rubygems
/usr/lib/ruby/1.8/rubygems.rb:578:in `report_activate_error': Could not find RubyGem hoe (>= 2.8.0) (Gem::LoadError)

which depends on RubyGems >= 1.2.1

:~# gem install hoe --version=2.8.0
ERROR:  Error installing hoe:
	hoe requires RubyGems version >= 1.3.1

which isn't what Debian comes with:

~# gem --version
1.2.0

That made rubygems-update useless for me :(



----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29080&group_id=126


More information about the Rubygems-developers mailing list