[Rubygems-developers] [ rubygems-Bugs-29056 ] RubyGems 1.6.0 seems to break Capistrano

noreply at rubyforge.org noreply at rubyforge.org
Thu Mar 3 14:17:14 EST 2011


Bugs item #29056, was opened at 2011-03-03 19:17
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29056&group_id=126

Category: other
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Dave Verwer (daveverwer)
Assigned to: Nobody (None)
Summary: RubyGems 1.6.0 seems to break Capistrano

Initial Comment:
This is going to be a fairly vague bug report and I apologise for that in advance, feel free to ignore if you can not reproduce.

I did a rubygems update and got 1.6.0, after that every time I ran cap, even something as innocuous as "cap -V" in a directory with no capfile in it I got the following error message:

/Library/Ruby/Site/1.8/rubygems.rb:267:in `activate': can't activate net-ssh (= 2.0.4) for [], already activated net-ssh-2.1.3 for [] (Gem::LoadError)

installing RubyGems 1.5.0 again fixes the problem.

Capistrano versions installed are:
capistrano (2.5.19, 2.5.2)

Net-SSH versions are:
net-ssh (2.1.3, 2.0.4, 1.1.4)



----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29056&group_id=126


More information about the Rubygems-developers mailing list