[Rubygems-developers] [ rubygems-Bugs-29053 ] YAML error when installing gem on jruby

noreply at rubyforge.org noreply at rubyforge.org
Thu Mar 3 07:31:38 EST 2011


Bugs item #29053, was opened at 2011-03-04 01:31
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29053&group_id=126

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: John Mair (banister)
Assigned to: Nobody (None)
Summary: YAML error when installing gem on jruby

Initial Comment:
john at littleblood ~ $ gem install pry
ERROR:  While executing gem ... (ArgumentError)
    undefined class/module YAML::Syck::DefaultKey

gem env output:
$ gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.6.0
  - RUBY VERSION: 1.8.7 (2010-09-28 patchlevel 249) [java]
  - INSTALLATION DIRECTORY: /home/john/.rvm/gems/jruby-1.5.3
  - RUBY EXECUTABLE: /home/john/.rvm/rubies/jruby-1.5.3/bin/jruby
  - EXECUTABLE DIRECTORY: /home/john/.rvm/gems/jruby-1.5.3/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - universal-java-1.6
  - GEM PATHS:
     - /home/john/.rvm/gems/jruby-1.5.3
     - /home/john/.rvm/gems/jruby-1.5.3 at global
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - "install" => "--env-shebang"
     - "update" => "--env-shebang"
     - "gem" => "--no-rdoc --no-ri"
  - REMOTE SOURCES:
     - http://rubygems.org/



----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=29053&group_id=126


More information about the Rubygems-developers mailing list