Dropping Ruby 1.8.x support for 2.0?

Erik Hollensbe erik at hollensbe.org
Mon Dec 19 19:36:36 EST 2011


A lot of people in the real world(™) still depend on 1.8.7. As much as it sucks, I can't see how this would go well for the rubygems project.

Maybe a spelled out deprecation roadmap would be a better way of saying "hey, 1.8.7 users, get your shit together".

-Erik

On Dec 19, 2011, at 4:25 PM, Luis Lavena wrote:

> Hello guys,
> 
> While working on my TODO notes found that we have a couple of things
> (like checks for tty?) that were broken in 1.8.7 but are fixed in
> 1.9.3.
> 
> Shall we consider EOL for Ruby 1.8.7 in RubyGems?
> 
> /me wants a smaller and cleaner codebase, so was wondering your thoughts?
> 
> Thank you.
> -- 
> Luis Lavena
> AREA 17
> -
> Perfection in design is achieved not when there is nothing more to add,
> but rather when there is nothing more to take away.
> Antoine de Saint-Exupéry
> _______________________________________________
> RubyGems-Developers mailing list
> http://rubyforge.org/projects/rubygems
> RubyGems-Developers at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rubygems-developers



More information about the RubyGems-Developers mailing list