[Rubygems-developers] [ rubygems-Bugs-28597 ] setup.rb with rubygems1.3.7 fails on running with ruby version 1.9.2, see traceback.

noreply at rubyforge.org noreply at rubyforge.org
Tue Oct 19 13:36:28 EDT 2010


Bugs item #28597, was opened at 2010-09-23 17:57
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28597&group_id=126

Category: RubyGems installer (setup.rb)
Group: v1.3.x
Status: Closed
Resolution: Rejected
Priority: 3
Submitted By: Dinesh Arora (dinesharora)
Assigned to: Nobody (None)
Summary: setup.rb with rubygems1.3.7 fails on running with ruby version 1.9.2, see traceback.

Initial Comment:

C:\RubyGems\rubygems-1.3.7>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\RubyGems\rubygems-1.3.7>

C:\RubyGems\rubygems-1.3.7>ruby setup.rb
C:/RubyGems/rubygems-1.3.7/lib/rubygems/source_index.rb:68:in `installed_spec_di
rectories': undefined method `path' for Gem:Module (NoMethodError)
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems/source_index.rb:58:in `from
_installed_gems'
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems.rb:883:in `source_index'
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:81:in
`init_gemspecs'
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:13:in
`initialize'
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems.rb:841:in `new'
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems.rb:841:in `block in searche
r'
        from <internal:prelude>:10:in `synchronize'
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems.rb:840:in `searcher'
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems.rb:479:in `find_files'
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems.rb:983:in `load_plugins'
        from C:/RubyGems/rubygems-1.3.7/lib/rubygems.rb:1139:in `<top (required)
>'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from setup.rb:24:in `<main>'

C:\RubyGems\rubygems-1.3.7>


----------------------------------------------------------------------

Comment By: Brian Rabbit (xuinkrbin)
Date: 2010-10-19 12:36

Message:
Wait, then, if One is trying to build Shoes, for example, and One builds Ruby 1.9.2, as described at http://github.com/shoes/shoes/wiki/BuildingShoesOnOSX (step #11), should One skip step #12, which is to compile RubyGems?

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2010-09-23 18:20

Message:
Ah, I see

I would recommend you open a ticket with Ruby on Rails website maintainers to improve these pages.

RubyGems is needed for 1.8.x version of Ruby. A clear omission in the step.
(And that is not 100% true as RubyInstaller actually bundle it for you ;-)

Regards.

----------------------------------------------------------------------

Comment By: Dinesh Arora (dinesharora)
Date: 2010-09-23 18:16

Message:
Thank you Luis for the quick reply. The documentation at 
rubyonrails.org is incorrect. It says to install ruby and 
then rubygems. Does not differentiate between versions 
1.8.x or 1.9.x. See http://rubyonrails.org/download 

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2010-09-23 18:07

Message:
You should not be attempting to install RubyGems on Ruby 1.9.1 or 1.9.2

RubyGems is bundled with Ruby since 1.9.1

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28597&group_id=126


More information about the Rubygems-developers mailing list