[Rubygems-developers] [ rubygems-Bugs-28723 ] `uninitialized constant Hoe::Deps::URI` when running `rake test`

noreply at rubyforge.org noreply at rubyforge.org
Tue Nov 16 00:45:47 EST 2010


Bugs item #28723, was opened at 2010-11-15 20:52
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28723&group_id=126

Category: other
Group: v1.3.x
Status: Closed
Resolution: Out of Date
Priority: 3
Submitted By: Josh Nichols (techpickles)
Assigned to: Nobody (None)
Summary: `uninitialized constant Hoe::Deps::URI` when running `rake test`

Initial Comment:
I've noticed this a few times when running tests on master:

$ rake test --trace
(in /Users/technicalpickles/code/vendor/rubygems)
rake aborted!
uninitialized constant Hoe::Deps::URI
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/lib/rake.rb:2503:in `const_missing'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/hoe-2.5.0/lib/hoe/deps.rb:17
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/hoe-2.5.0/lib/hoe.rb:243:in `load'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/hoe-2.5.0/lib/hoe.rb:243:in `load_plugins'
/Users/technicalpickles/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `map'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/hoe-2.5.0/lib/hoe.rb:238:in `each'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/hoe-2.5.0/lib/hoe.rb:238:in `map'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/hoe-2.5.0/lib/hoe.rb:238:in `load_plugins'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/hoe-2.5.0/lib/hoe.rb:288:in `spec'
/Users/technicalpickles/code/vendor/rubygems/Rakefile:12
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/lib/rake.rb:2383:in `load'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/lib/rake.rb:2383:in `raw_load_rakefile'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/lib/rake.rb:2017:in `load_rakefile'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/lib/rake.rb:2016:in `load_rakefile'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/lib/rake.rb:2000:in `run'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/gems/rake-0.8.7/bin/rake:31
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/bin/rake:19:in `load'
/Users/technicalpickles/.rvm/gems/ruby-1.8.7-p249/bin/rake:19


For reference, this is ruby 1.8.7, with the relevant gems being hoe 2.5.0, rake 0.8.7, minitest 2.0.0.

I'm able to work around this by using `rake test -ruri`.

----------------------------------------------------------------------

>Comment By: Josh Nichols (techpickles)
Date: 2010-11-16 00:45

Message:
To follow up, hoe 2.7.0 works fine. Not sure if there's any way to either force the 
use of a recent enough hoe, or warn about an old version, but that'd be pretty 
nice.

----------------------------------------------------------------------

Comment By: James Tucker (raggi)
Date: 2010-11-16 00:32

Message:
This is fixed in the latest Hoe.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28723&group_id=126


More information about the Rubygems-developers mailing list