[Rubygems-developers] [ rubygems-Bugs-28715 ] unable to install rubygems from .tar.gz to 1.9.2

noreply at rubyforge.org noreply at rubyforge.org
Sat Nov 13 13:06:52 EST 2010


Bugs item #28715, was opened at 2010-11-13 08:31
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28715&group_id=126

Category: RubyGems installer (setup.rb)
Group: None
>Status: Closed
>Resolution: Rejected
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: unable to install rubygems from .tar.gz to 1.9.2

Initial Comment:
viz:

D:\dev\downloads\rubygems-1.3.7>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

D:\dev\downloads\rubygems-1.3.7>ruby setup.rb
D:/dev/downloads/rubygems-1.3.7/lib/rubygems/source_index.rb:68:in `installed_spec_directories': undefined method `path' for Gem:Module (NoMethodError)
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems/source_index.rb:58:in `from_installed_gems'
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems.rb:883:in `source_index'
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:81:in `init_gemspecs'
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:13:in `initialize'
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems.rb:841:in `new'
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems.rb:841:in `block in searcher'
        from <internal:prelude>:10:in `synchronize'
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems.rb:840:in `searcher'
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems.rb:479:in `find_files'
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems.rb:983:in `load_plugins'
        from D:/dev/downloads/rubygems-1.3.7/lib/rubygems.rb:1139:in `<top (required)>'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from setup.rb:24:in `<main>'



----------------------------------------------------------------------

>Comment By: Ryan Davis (zenspider)
Date: 2010-11-13 10:06

Message:
So don't do that.

% ~/.multiruby/install/1.9.2-p0/bin/ruby -S gem -v
1.3.7


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28715&group_id=126


More information about the Rubygems-developers mailing list