[Rubygems-developers] [ rubygems-Bugs-28238 ] gem update fails when released gem is outdated but a prerelease is installed

noreply at rubyforge.org noreply at rubyforge.org
Sat Nov 13 08:55:17 EST 2010


Bugs item #28238, was opened at 2010-05-23 11:23
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28238&group_id=126

Category: `gem` commands (other)
Group: v1.3.x
>Status: Closed
>Resolution: Rejected
Priority: 3
Submitted By: Caio Chassot (cchassot)
Assigned to: John Barnette (jbarnette)
Summary: gem update fails when released gem is outdated but a prerelease is installed

Initial Comment:
somewhat related to #28237

Eg. rails 2.3.5 won't update to 2.3.6 is 3.0.0.beta3 is installed.

I think I fixed this by handling option[:prerelease] in update_command, but now when I run `gem update --pre` it insists in installing sinatra 1.0.b every time.

FWIW:
$ gem1.9 list sinatra
*** LOCAL GEMS ***
sinatra (1.0, 1.0.b, 1.0.a, 0.9.4, 0.9.2)



----------------------------------------------------------------------

Comment By: Caio Chassot (cchassot)
Date: 2010-05-26 10:15

Message:
I hear what you're saying, but is there any downside to being smart about 
updating released gems regardless of having a larger version installed as pre-
release?


> (but that appears to be a separate issue, please file a separate ticket for it).

I'll gladly open said ticket, but what issue exactly are you talking about here?

----------------------------------------------------------------------

Comment By: Eric Hodel (drbrain)
Date: 2010-05-25 15:27

Message:
2.3.6 is a lesser version than 3.0.0.beta3.

If you want to install a lesser version than one you already have installed use `gem install rails --version 2.3.6`.

If you elect to use prereleases you can expect to have to do more work in managing your gems.

`gem update --prerelease` means "allow updating to prerelease versions", so the behavior you're seeing is correct (but that appears to be a separate issue, please file a separate ticket for it).

----------------------------------------------------------------------

Comment By: Caio Chassot (cchassot)
Date: 2010-05-23 11:29

Message:
Obviously I meant:


Eg. rails 2.3.5 won't update to 2.3.6 BECAUSE 3.0.0.beta3 is installed.


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28238&group_id=126


More information about the Rubygems-developers mailing list