[Rubygems-developers] [CruiseControl] RubyGemsGitHub build dd64b5d failed

devnull+rubygems-ci at pivotallabs.com devnull+rubygems-ci at pivotallabs.com
Sat Nov 13 02:18:35 EST 2010


The build failed.

CHANGES
-------
Revision ...dd64b5d05cf0d832b0ae26eee6f1113866dd4863 committed by Ryan Davis <ryand-ruby at zenspider.com> on 2010-11-13 06:56:25

    Added testcase brainstormed with raggi. Refactored tests with new assert_resolve

 test/test_gem_dependency_installer.rb |   61 +++++++++++++++++++--------------
 1 files changed, 35 insertions(+), 26 deletions(-)
Revision ...01da38355caf6cd16b8b081abbbe3ea0e0e2d1ee committed by Ryan Davis <ryand-ruby at zenspider.com> on 2010-11-13 06:55:53

    minor refactoring for readibility

 lib/rubygems/dependency_installer.rb |   55 +++++++++++++++++++---------------
 1 files changed, 31 insertions(+), 24 deletions(-)
Revision ...cc8088b8e8150b2c24bec981a28d0764d5dfc7fb committed by Ryan Davis <ryand-ruby at zenspider.com> on 2010-11-13 06:53:32

    Added minor clarification

 lib/rubygems/dependency_list.rb |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)



TEST FAILURES AND ERRORS
-----------------------
Name: test_gather_dependencies_raggi_the_edgecase_generator(TestGemDependencyInstaller)
Type: Failure
Message: Expected ["b-1.0", "c-1.0", "a-1.0"], not ["b-1.1", "c-1.0", "a-1.0"].

./test/test_gem_dependency_installer.rb:654


Name: test_gather_dependencies_dropped(TestGemDependencyInstaller)
Type: Failure
Message: Expected ["b-2", "c-1"], not ["a-1"].

./test/test_gem_dependency_installer.rb:635


Name: test_gather_dependencies_divergent(TestGemDependencyInstaller)
Type: Failure
Message: Gem::DependencyError expected but nothing was raised.

./test/test_gem_dependency_installer.rb:713


Name: test_gather_dependencies_over(TestGemDependencyInstaller)
Type: Failure
Message: Expected ["b-1.0", "c-1.0", "a-1.0"], not ["b-2.0", "c-1.0", "a-1.0"].

./test/test_gem_dependency_installer.rb:671


Name: test_gather_dependencies_under(TestGemDependencyInstaller)
Type: Failure
Message: Expected ["b-1.0", "c-1.0", "a-1.0"], not ["b-1.1", "c-1.0", "a-1.0"].

./test/test_gem_dependency_installer.rb:691




See http://ci.pivotallabs.com:3333/builds/RubyGemsGitHub/dd64b5d05cf0d832b0ae26eee6f1113866dd4863 for details.


More information about the Rubygems-developers mailing list