[Rubygems-developers] [ rubygems-Bugs-28491 ] fetch a specific prerelease version

noreply at rubyforge.org noreply at rubyforge.org
Fri Nov 12 23:36:23 EST 2010


Bugs item #28491, was opened at 2010-08-19 15:30
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28491&group_id=126

Category: `gem` commands (remote behavior)
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: gabriel horner (cldwalker)
>Assigned to: John Barnette (jbarnette)
Summary: fetch a specific prerelease version

Initial Comment:
I can't fetch a specific prerelease version:
  $ gem fetch dm-core -v '1.0.0.rc2' --pre --debug
   Exception `NameError' at /Users/bozo/.rvm/rubies/ruby-1.8.7-p299/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:164 - uninitialized constant Gem::Commands::FetchCommand
   Exception `OptionParser::InvalidOption' at /Users/bozo/.rvm/rubies/ruby-1.8.7-p299/lib/ruby/1.8/optparse.rb:1450 - invalid option: no-ri
   Exception `OptionParser::InvalidOption' at /Users/bozo/.rvm/rubies/ruby-1.8.7-p299/lib/ruby/1.8/optparse.rb:1263 - invalid option: --no-ri
   ERROR:  Could not find a valid gem 'dm-core' (= 1.0.0.rc2) in any repository
  
I'm aware I can fetch the latest prerelease version: gem fetch dm-core --pre
but I need specific prerelease versions of gems. Is this possible?

FYI, I originally asked about this on help.rubygems.org: http://help.rubygems.org/discussions/questions/38-gem-fetch-a-specific-prerelease-version

My gem environment:

$ gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.7
  - RUBY VERSION: 1.8.7 (2010-06-23 patchlevel 299) [i686-darwin9.4.0]
  - INSTALLATION DIRECTORY: /Users/bozo/.rvm/gems/ruby-1.8.7-p299 at ext
  - RUBY EXECUTABLE: /Users/bozo/.rvm/rubies/ruby-1.8.7-p299/bin/ruby
  - EXECUTABLE DIRECTORY: /Users/bozo/.rvm/gems/ruby-1.8.7-p299 at ext/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-darwin-9
  - GEM PATHS:
     - /Users/bozo/.rvm/gems/ruby-1.8.7-p299 at ext
     - /Users/bozo/.rvm/gems/ruby-1.8.7-p299 at global
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - "gem" => "--no-ri"
     - :sources => ["http://rubygems.org"]
  - REMOTE SOURCES:
     - http://rubygems.org

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28491&group_id=126


More information about the Rubygems-developers mailing list