[Rubygems-developers] [ rubygems-Bugs-28486 ] unable to use runtime dependencies in mkrf_conf.rb

noreply at rubyforge.org noreply at rubyforge.org
Fri Nov 12 23:34:31 EST 2010


Bugs item #28486, was opened at 2010-08-18 17:29
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28486&group_id=126

Category: `gem install` command
Group: None
>Status: Closed
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: unable to use runtime dependencies in mkrf_conf.rb

Initial Comment:
Situation currently:

if you have the following in your mkrf_conf.rb file


require 'rubygems'
require 'some dependency gem'

and your gemspec lists "some dependency gem" as a runtime dependency, your gem will fail to install the first time, then install correctly when you attempt to install it a second time.  I would have expected runtime dependencies to be available at build time of the main gem.
Thanks!
-r

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28486&group_id=126


More information about the Rubygems-developers mailing list