[Rubygems-developers] [ rubygems-Bugs-28419 ] gem install and gem update commands fail

noreply at rubyforge.org noreply at rubyforge.org
Fri Nov 12 23:33:26 EST 2010


Bugs item #28419, was opened at 2010-07-24 18:36
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28419&group_id=126

Category: `gem install` command
Group: None
>Status: Closed
Resolution: None
Priority: 3
Submitted By: Radu Popescu (radascuta)
Assigned to: Nobody (None)
Summary: gem install and gem update commands fail

Initial Comment:
I get this error when trying to upgrade to Rail 2.2.2 from 2.0.2:

Updating installed gems...
ERROR:  While executing gem ... (Gem::RemoteSourceException)
    HTTP Response 301 fetching http://gems.rubyforge.org/yaml

I get the very same error for both %>gem install rails --version 2.2.2 and %>gem update rails.

Any ideas? 
Thank you. 

----------------------------------------------------------------------

>Comment By: Ryan Davis (zenspider)
Date: 2010-11-12 20:33

Message:
Rubygems requires the following features that are part of a standard ruby 
distribution:

zlib
rdoc
openssl
etc

If your ruby complains about any of these files your ruby is broken.  You need to 
install the missing parts of ruby.  Please contact your ruby packager and tell them 
not to break ruby.

----------------------------------------------------------------------

Comment By: Ryan Davis (zenspider)
Date: 2010-11-12 20:33

Message:
no response. assumed fixed.

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2010-07-24 18:52

Message:
Please update your gem sources to http://rubygems.org, removing the gems.rubyforge.org source.

Gem sources are in ~/.gemrc


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28419&group_id=126


More information about the Rubygems-developers mailing list