[Rubygems-developers] [ rubygems-Bugs-27802 ] ruby-1.9.1 causes defaults/operating_system.rb to be overridden by defaults.rb

noreply at rubyforge.org noreply at rubyforge.org
Fri Nov 12 18:44:57 EST 2010


Bugs item #27802, was opened at 2010-02-09 14:14
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27802&group_id=126

Category: None
Group: v1.3.x
>Status: Closed
>Resolution: Rejected
Priority: 3
Submitted By: Richard Brown (rbrown)
Assigned to: Nobody (None)
Summary: ruby-1.9.1 causes defaults/operating_system.rb to be overridden by defaults.rb

Initial Comment:
In ruby-1.9.1p376 gem_prelude requires defaults/opearting_system.rb

If rubygems-1.3.5 is required it requires defaults.rb. Although defaults.rb does require defaults/operating_system.rb ruby won't re-load a library that's already in $". This means that anything set in defaults/operating_system.rb is being overridden by defaults.rb.

----------------------------------------------------------------------

>Comment By: Ryan Davis (zenspider)
Date: 2010-11-12 15:44

Message:
IDGI. I don't see how this is a problem in 1.9 w/ $" being expanded.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27802&group_id=126


More information about the Rubygems-developers mailing list