[Rubygems-developers] [ rubygems-Bugs-27324 ] string contains null byte

noreply at rubyforge.org noreply at rubyforge.org
Fri Nov 12 17:46:27 EST 2010


Bugs item #27324, was opened at 2009-10-21 02:41
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27324&group_id=126

Category: `gem install` command
Group: v1.3.x
>Status: Closed
Resolution: None
Priority: 3
Submitted By: Thomas Preymesser (thopre)
Assigned to: Nobody (None)
Summary: string contains null byte 

Initial Comment:
Hello,

i get this error when i try to install rails. 
Many other gems can be installed without problems.


$ sudo gem install  rails --backtrace
ERROR:  While executing gem ... (ArgumentError)
    string contains null byte
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package/tar_reader/entry.rb:66:in `join'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package/tar_reader/entry.rb:66:in `full_name'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package/tar_input.rb:32:in `block in initialize'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package/tar_reader.rb:63:in `block in each'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package/tar_reader.rb:54:in `loop'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package/tar_reader.rb:54:in `each'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package/tar_input.rb:31:in `initialize'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package/tar_input.rb:16:in `new'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package/tar_input.rb:16:in `open'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/package.rb:56:in `open'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/format.rb:67:in `from_io'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/format.rb:51:in `block in from_file_by_path'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/format.rb:50:in `open'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/format.rb:50:in `from_file_by_path'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/installer.rb:119:in `initialize'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/dependency_installer.rb:239:in `new'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/dependency_installer.rb:239:in `block in install'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/dependency_installer.rb:222:in `each'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/dependency_installer.rb:222:in `install'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/commands/install_command.rb:118:in `block in execute'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/commands/install_command.rb:115:in `each'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/commands/install_command.rb:115:in `execute'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/command.rb:257:in `invoke'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/command_manager.rb:132:in `process_args'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/command_manager.rb:102:in `run'
	/usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/gem_runner.rb:58:in `run'
	/usr/local/bin/gem:21:in `<main>'

$ gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.5
  - RUBY VERSION: 1.9.2 (2009-10-21 patchlevel -1) [i686-linux]
  - INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.9.1
  - RUBYGEMS PREFIX: /usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5
  - RUBY EXECUTABLE: /usr/local/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/local/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-linux
  - GEM PATHS:
     - /usr/local/lib/ruby/gems/1.9.1
     - /home/tp/.gem/ruby/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - :sources => ["http://gems.rubyforge.org/"]
     - "rdoc" => "--inline-source --line-numbers --format=html --template=hanna"
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/


----------------------------------------------------------------------

Comment By: Ryan Davis (zenspider)
Date: 2010-11-12 14:46

Message:
This ticket has been deemed stale and we're closing it in order to catch up 
with our ticket list. If you think it is still valid, please reopen.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27324&group_id=126


More information about the Rubygems-developers mailing list