[Rubygems-developers] [ rubygems-Bugs-22965 ] Gem activation fails because version requirement not correctly honored in its dependencies

noreply at rubyforge.org noreply at rubyforge.org
Fri Nov 12 17:46:25 EST 2010


Bugs item #22965, was opened at 2008-11-24 15:17
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=22965&group_id=126

Category: #gem and #require methods
Group: v1.3.x
>Status: Closed
Resolution: Accepted
Priority: 3
Submitted By: Pascal Hurni (phi)
Assigned to: Eric Hodel (drbrain)
Summary: Gem activation fails because version requirement not correctly  honored in its dependencies

Initial Comment:
Hi,

I have a scenario in my project with multiple dependencies. The problem is that rubygems will fail when activating the gems while the overall requirements are valid.

Here is the context:
  installed gems are: activesupport 2.0.2, activesupport 2.1.0,
actionpack 2.0.2, actionpack 2.1.0, mygem 1.0

  Main app => depends on:
    activesupport, '= 2.0.2'
    mygem => depends on:
      activesupport, '>= 1.4.0'
      actionpack, '>= 2.0.2'
      
The problem arise from the last requirement which is actionpack
>= 2.0.2.
The current implementation will load actionpack 2.1.0 but fail
when loading its dependencies
because one of them is activesupport, '= 2.1.0' (the equal sign
is very important here!).
It should have continued to try other version of actionpack until 2.0.2.

Prem proposed a patch [#22272] which didn't resolve my issue. (You may read the discussion)

I submit a patch against rubygems 1.3.1 to fix this issue.

Regards,

Pascal

For info, part of my RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.1
  - RUBY VERSION: 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
  - INSTALLATION DIRECTORY: D:/Dev/Lang/Ruby/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: D:/Dev/Lang/Ruby/bin/ruby.exe


----------------------------------------------------------------------

Comment By: Ryan Davis (zenspider)
Date: 2010-11-12 14:46

Message:
This ticket has been deemed stale and we're closing it in order to catch up 
with our ticket list. If you think it is still valid, please reopen.

----------------------------------------------------------------------

Comment By: Eric Hodel (drbrain)
Date: 2009-03-27 14:56

Message:
This seems to be with dup of #21154.

I'll need to write some tests before applying this patch, it seems complicated.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=22965&group_id=126


More information about the Rubygems-developers mailing list