[Rubygems-developers] [ rubygems-Bugs-27960 ] rubygems 1.3.6 can't fetch a gem with a version other than the newest version

noreply at rubyforge.org noreply at rubyforge.org
Fri Mar 12 13:21:27 EST 2010


Bugs item #27960, was opened at 2010-03-12 12:21
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27960&group_id=126

Category: `gem` commands (remote behavior)
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Eric Hankins (stormsilver)
Assigned to: Nobody (None)
Summary: rubygems 1.3.6 can't fetch a gem with a version other than the newest version

Initial Comment:
It seems that with the newest version of rubygems, gem fetch can only fetch the newest version of a gem. If you specify any version other than the newest one in a given repo, it tells you that it cannot find the gem. Here is an example session showing the problem with activesupport, but it happens with any gem.

# gem -v
1.3.6


# ruby -v
ruby 1.8.6 (2008-08-11 patchlevel 287) [x86_64-linux]


# gem sources
*** CURRENT SOURCES ***

http://rubygems.org


# gem list -r -a activesupport

*** REMOTE GEMS ***

activesupport (2.3.5, 2.3.4, 2.3.3, 2.3.2, 2.2.3, 2.2.2, 2.1.2, 2.1.1, 2.1.0, 2.0.5, 2.0.4, 2.0.2, 2.0.1, 2.0.0, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.1, 1.3.0, 1.2.5, 1.2.4, 1.2.3, 1.2.2, 1.2.1, 1.1.1, 1.1.0, 1.0.4, 1.0.3, 1.0.2, 1.0.1, 1.0.0)
activesupport-jcache (0.1.0)


# gem fetch activesupport -v 2.3.2
ERROR:  Could not find activesupport in any repository


# gem fetch activesupport -v "=2.3.2"
ERROR:  Could not find activesupport in any repository


# gem fetch activesupport -v "=2.3.4"
ERROR:  Could not find activesupport in any repository


# gem fetch activesupport -v "=2.3.5"
Downloaded activesupport-2.3.5

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27960&group_id=126


More information about the Rubygems-developers mailing list