[Rubygems-developers] [ rubygems-Patches-27951 ] Add support for IronRuby-specific gems

noreply at rubyforge.org noreply at rubyforge.org
Wed Mar 10 00:52:36 EST 2010


Patches item #27951, was opened at 2010-03-10 00:52
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=577&aid=27951&group_id=126

Category: `gem install`
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Will Green (hotgazpacho)
Assigned to: Nobody (None)
Summary: Add support for IronRuby-specific gems

Initial Comment:
This patch adds support for IronRuby-specific gems (gems that have C# extensions, or that otherwise make use of .Net libraries), so that IronRuby can install them from remote sources. For 1.0, IronRuby will support 3 targets:

* universal-.net     = The version of the CLR does not matter
* universal-.net-2.0 = Version 2.0 of the CLR is required
* universal-.net-4.0 = The forthcoming Version 4.0 of the CLR is required

The platform tests have been updated to reflect these 3 cases, but the regex implemented for version detection is flexible enough to allow for arbitrary major.minor versions.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=577&aid=27951&group_id=126


More information about the Rubygems-developers mailing list