[Rubygems-developers] [ rubygems-Bugs-27944 ] require does not populate Gem.loaded_specs under Ruby 1.9.1.

noreply at rubyforge.org noreply at rubyforge.org
Mon Mar 8 20:50:30 EST 2010


Bugs item #27944, was opened at 2010-03-09 01:50
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27944&group_id=126

Category: #gem and #require methods
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: postmodern  (postmodern)
>Assigned to: Eric Hodel (drbrain)
Summary: require does not populate Gem.loaded_specs under Ruby 1.9.1.

Initial Comment:
I recently upgraded to RubyGems 1.3.6 under Ruby 1.8.7 and 1.9.1. I noticed that *only* under Ruby 1.9.1, the 'require' method would not populate Gem.loaded_specs:

    >> RUBY_VERSION
    # => "1.9.1"
    >> Gem.loaded_specs
    # => {}
    >> require 'rack'
    # => true
    >> Gem.loaded_specs
    # => {}



----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27944&group_id=126


More information about the Rubygems-developers mailing list