[Rubygems-developers] [ rubygems-Bugs-27917 ] A warning occurs when I run gem update --system (Ruby 1.9.1)

noreply at rubyforge.org noreply at rubyforge.org
Thu Mar 4 02:28:35 EST 2010


Bugs item #27917, was opened at 2010-03-03 00:42
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27917&group_id=126

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: katherine pe (bridgeutopia)
Assigned to: Nobody (None)
Summary: A warning occurs when I run gem update --system (Ruby 1.9.1)

Initial Comment:
$ gem update --system
WARNING:  /usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:12: invalid multibyte char (UTF-8)
/usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:12: syntax error, unexpected tIDENTIFIER, expecting keyword_end
...d heavily on Mauricio Fern?ndez's implementation in rpa-base...
...                               ^
/usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:31: syntax error, unexpected tFLOAT, expecting keyword_end
...rsion) >= Gem::Version.new('1.2.0') then
...                               ^
/usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:31: no .<digit> floating literal anymore; put 0 before dot
...sion) >= Gem::Version.new('1.2.0') then
...                               ^
/usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:31: unterminated string meets end of file
WARNING:  # -*- encoding: utf-8 -*-

Gem::Specification.new do |s|
  s.name = %q{archive-tar-minitar}
  s.version = "0.5.1"

  s.required_rubygems_version = nil if s.respond_to? :required_rubygems_version=
  s.autorequire = %q{archive/tar/minitar}
  s.cert_chain = nil
  s.date = %q{2004-09-27}
  s.default_executable = %q{minitar}
  s.description = %q{Archive::Tar::Minitar is a pure-Ruby library and command-line utility that provides the ability to deal with POSIX tar(1) archive files. The implementation is based heavily on Mauricio Fern?ndez's implementation in rpa-base, but has been reorganised to promote reuse in other projects.}
  s.email = %q{minitar at halostatue.ca}
  s.executables = ["minitar"]
  s.extra_rdoc_files = ["README", "ChangeLog", "Install"]
  s.files = ["bin", "ChangeLog", "Install", "lib", "Rakefile", "README", "tests", "bin/minitar", "lib/archive", "lib/archive/tar", "lib/archive/tar/minitar", "lib/archive/tar/minitar.rb", "lib/archive/tar/minitar/command.rb", "tests/tc_tar.rb", "tests/testall.rb"]
  s.has_rdoc = true
  s.homepage = %q{http://rubyforge.org/projects/ruwiki/}
  s.rdoc_options = ["--title", "Archive::Tar::MiniTar -- A POSIX tarchive library", "--main", "README", "--line-numbers"]
  s.require_paths = ["lib"]
  s.required_ruby_version = Gem::Requirement.new(">= 1.8.1")
  s.rubyforge_project = %q{ruwiki}
  s.rubygems_version = %q{1.3.1}
  s.summary = %q{Provides POSIX tarchive management from Ruby programs.}
  s.test_files = ["tests/testall.rb"]

  if s.respond_to? :specification_version then
    current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
    s.specification_version = 1

    if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
    else
    end
  else
  end
end
WARNING:  /usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:12: invalid multibyte char (UTF-8)
/usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:12: syntax error, unexpected tIDENTIFIER, expecting keyword_end
...d heavily on Mauricio Fern?ndez's implementation in rpa-base...
...                               ^
/usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:31: syntax error, unexpected tFLOAT, expecting keyword_end
...rsion) >= Gem::Version.new('1.2.0') then
...                               ^
/usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:31: no .<digit> floating literal anymore; put 0 before dot
...sion) >= Gem::Version.new('1.2.0') then
...                               ^
/usr/lib/ruby/gems/1.8/specifications/archive-tar-minitar-0.5.1.gemspec:31: unterminated string meets end of file
WARNING:  # -*- encoding: utf-8 -*-

Gem::Specification.new do |s|
  s.name = %q{archive-tar-minitar}
  s.version = "0.5.1"

  s.required_rubygems_version = nil if s.respond_to? :required_rubygems_version=
  s.autorequire = %q{archive/tar/minitar}
  s.cert_chain = nil
  s.date = %q{2004-09-27}
  s.default_executable = %q{minitar}
  s.description = %q{Archive::Tar::Minitar is a pure-Ruby library and command-line utility that provides the ability to deal with POSIX tar(1) archive files. The implementation is based heavily on Mauricio Fern?ndez's implementation in rpa-base, but has been reorganised to promote reuse in other projects.}
  s.email = %q{minitar at halostatue.ca}
  s.executables = ["minitar"]
  s.extra_rdoc_files = ["README", "ChangeLog", "Install"]
  s.files = ["bin", "ChangeLog", "Install", "lib", "Rakefile", "README", "tests", "bin/minitar", "lib/archive", "lib/archive/tar", "lib/archive/tar/minitar", "lib/archive/tar/minitar.rb", "lib/archive/tar/minitar/command.rb", "tests/tc_tar.rb", "tests/testall.rb"]
  s.has_rdoc = true
  s.homepage = %q{http://rubyforge.org/projects/ruwiki/}
  s.rdoc_options = ["--title", "Archive::Tar::MiniTar -- A POSIX tarchive library", "--main", "README", "--line-numbers"]
  s.require_paths = ["lib"]
  s.required_ruby_version = Gem::Requirement.new(">= 1.8.1")
  s.rubyforge_project = %q{ruwiki}
  s.rubygems_version = %q{1.3.1}
  s.summary = %q{Provides POSIX tarchive management from Ruby programs.}
  s.test_files = ["tests/testall.rb"]

  if s.respond_to? :specification_version then
    current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
    s.specification_version = 1

    if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
    else
    end
  else
  end
end


----------------------------------------------------------------------

>Comment By: Eric Hodel (drbrain)
Date: 2010-03-03 23:28

Message:
If this is ruby 1.9 why does the directory say 1.8?

Did you install this gem with ruby 1.9?

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27917&group_id=126


More information about the Rubygems-developers mailing list