[Rubygems-developers] gem install --development ?

Luis Lavena luislavena at gmail.com
Thu Jul 29 08:53:02 EDT 2010


On Thu, Jul 29, 2010 at 1:39 AM, Nick Quaranto <nick at quaran.to> wrote:
> Does this...work?
>
> /tmp % gem install paperclip --development -V
> GET http://rubygems.org/latest_specs.4.8.gz
> 302 Found
> GET http://production.s3.rubygems.org/latest_specs.4.8.gz
> 304 Not Modified
> GET http://rubygems.org/specs.4.8.gz
> 302 Found
> GET http://production.s3.rubygems.org/specs.4.8.gz
> 304 Not Modified
>
> Installing gem hoe-2.6.1
> ERROR:  Error installing paperclip:
>        hoe requires minitest (>= 1.6.0, development)
>
> Seems like paperclip's development dependency hits sqlite3-ruby, which has a
> dev dependency on hoe, which has a dev dependency on minitest, which has a
> dev dependency on hoe....
>
> Any ideas on what we can do to make this work once again?

I believe this is similar to the recursive runtime dependency issue we
had with 1.3.5:

http://rubyforge.org/pipermail/rubygems-developers/2009-December/005132.html

Seems we need an example for development dependencies too.

-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Rubygems-developers mailing list