[Rubygems-developers] [ rubygems-Bugs-27841 ] gem prelude appears to prefer older versions of gems at times

noreply at rubyforge.org noreply at rubyforge.org
Mon Jul 19 09:36:48 EDT 2010


Bugs item #27841, was opened at 2010-02-16 14:57
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27841&group_id=126

Category: #gem and #require methods
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: gem prelude appears to prefer older versions of gems at times

Initial Comment:
Currently on doze, if I install the ffi gem with the following two version:


ffi-0.5.4-x86-mingw32

ffi-0.6.2 (from source)

gem prelude appears to "prefer" 0.5.4 even though it's older.

c:\dev_old\digitalarchive_trunk>gem search ffi

*** LOCAL GEMS ***

ffi (0.6.2, 0.6.0, 0.5.4)

c:\dev_old\digitalarchive_trunk>ruby -v  -rffi -e 'puts $LOADED_FEATURES.grep(/ffi/)'
ruby 1.9.1p376 (2009-12-07 revision 26041) [i386-mingw32]
E:/installs/ruby191p376/lib/ruby/gems/1.9.1/gems/ffi-0.5.4-x86-mingw32/lib/1.9/ffi_c.so
E:/installs/ruby191p376/lib/ruby/gems/1.9.1/gems/ffi-0.5.4-x86-mingw32/lib/ffi/platform.rb
...

Thanks!
-rp

----------------------------------------------------------------------

>Comment By: James Tucker (raggi)
Date: 2010-07-19 13:36

Message:
Sigh, prelude, roger, is this bug still active?


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27841&group_id=126


More information about the Rubygems-developers mailing list