[Rubygems-developers] [ rubygems-Bugs-27700 ] unable to load gems *ever* if --disable-gems is passed [1.9]

noreply at rubyforge.org noreply at rubyforge.org
Mon Jan 18 23:37:07 EST 2010


Bugs item #27700, was opened at 2010-01-19 04:37
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27700&group_id=126

Category: #gem and #require methods
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: unable to load gems *ever* if --disable-gems is passed [1.9]

Initial Comment:
Appears that this file fails

require 'rubygems'
require 'os'

in 1.9
if you start Ruby with --disable-gems

This was surprising to me, because I assumed that doing a
require 'rubygems'
would "re-enable" rubygems.
Perhaps I am wrong?
Thanks.
-r

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27700&group_id=126


More information about the Rubygems-developers mailing list