[Rubygems-developers] [ rubygems-Bugs-27868 ] rubygems 1.3.6 isn't compatible with rails 2.2.2

noreply at rubyforge.org noreply at rubyforge.org
Mon Feb 22 20:40:45 EST 2010


Bugs item #27868, was opened at 2010-02-22 13:08
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27868&group_id=126

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Wei Jen Lu (weijenlu)
Assigned to: Nobody (None)
Summary: rubygems 1.3.6 isn't compatible with rails 2.2.2

Initial Comment:
I updated rubygems to 1.3.6 and run my app which using rails 2.2.2. My app has exception: 

/Users/weijen/.gem/ruby/1.8/gems/rails-2.2.2/lib/rails/gem_dependency.rb:224:in `specification': undefined method `version_requirements=' for #<Gem::Dependency:0x24d2fe0> (NoMethodError)
        from /Users/weijen/.gem/ruby/1.8/gems/rails-2.2.2/lib/rails/plugin/locator.rb:81:in `plugins'
        from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `inject'
        from /Users/weijen/.gem/ruby/1.8/gems/rails-2.2.2/lib/rails/plugin/locator.rb:81:in `each'
        from /Users/weijen/.gem/ruby/1.8/gems/rails-2.2.2/lib/rails/plugin/locator.rb:81:in `inject'
        from /Users/weijen/.gem/ruby/1.8/gems/rails-2.2.2/lib/rails/plugin/locator.rb:81:in `plugins'
        from /Users/weijen/.gem/ruby/1.8/gems/rails-2.2.2/lib/rails/plugin/loader.rb:63:in `locate_plugins'
        from /Users/weijen/.gem/ruby/1.8/gems/rails-2.2.2/lib/rails/plugin/loader.rb:62:in `map'
        from /Users/weijen/.gem/ruby/1.8/gems/rails-2.2.2/lib/rails/plugin/loader.rb:62:in `locate_plugins'
         ... 34 levels...
        from /Users/weijen/.gem/ruby/1.8/gems/rails-2.2.2/lib/commands/server.rb:49
        from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
        from script/server:3

If I rollback to 1.3.5, then everything is fine.

Please help me. thanks.

My platform:

OS: Mac OS X 10.5.8
Ruby:  ruby 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0]

Wei Jen

----------------------------------------------------------------------

Comment By: Vidal Graupera (vgraupera)
Date: 2010-02-23 01:40

Message:
I hit the exact same problem. 

My platform is OS X 10.6.2 and ruby 1.8.7 (2008-08-11 patchlevel 72) [universal-darwin10.0]




----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27868&group_id=126


More information about the Rubygems-developers mailing list