[Rubygems-developers] [ rubygems-Feature Requests-27873 ] make the gem which command obey "require" like semantics

noreply at rubyforge.org noreply at rubyforge.org
Mon Feb 22 14:56:05 EST 2010


Feature Requests item #27873, was opened at 2010-02-22 19:56
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=578&aid=27873&group_id=126

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: make the gem which command obey "require" like semantics

Initial Comment:
Currently:

c:\dev_old\digitalarchive_trunk>gem which rubygems.rb
ERROR:  Can't find ruby library file or shared library rubygems.rb

c:\dev_old\digitalarchive_trunk>gem which rubygems
E:/installs/ruby191p376/lib/ruby/site_ruby/1.9.1/rubygems.rb


Feature request:

allow "require" like semantics, which allows an optional extension (if it's the right one), i.e.

c:\dev_old\digitalarchive_trunk>gem which rubygems.rb
E:/installs/ruby191p376/lib/ruby/site_ruby/1.9.1/rubygems.rb


Thanks.
-r


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=578&aid=27873&group_id=126


More information about the Rubygems-developers mailing list