[Rubygems-developers] [ rubygems-Feature Requests-27871 ] allow for transitive dependencies across hosts

noreply at rubyforge.org noreply at rubyforge.org
Mon Feb 22 12:04:06 EST 2010


Feature Requests item #27871, was opened at 2010-02-22 17:04
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=578&aid=27871&group_id=126

Category: `gem install` command
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: allow for transitive dependencies across hosts

Initial Comment:
The basic error is this:



E:\downloads\ruby-1.8.6-p398-i386-mingw32\ruby-1.8.6-p388-i386-mingw32\bin>gem install rogerdpack-desc_method -v0.1.5 --source=http://gems.github.com --source=http://rubygems.org
ERROR:  Error installing rogerdpack-desc_method:
        ruby2ruby requires ruby_parser (~> 2.0, runtime)


(ruby_parser is indeed there--on rubygems.org--it just doesn't install it right).

ref:
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27169&group_id=126

Thanks.
-r

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=578&aid=27871&group_id=126


More information about the Rubygems-developers mailing list