[Rubygems-developers] [ rubygems-Feature Requests-27767 ] feature request: don't load plugins of outdated gems

noreply at rubyforge.org noreply at rubyforge.org
Tue Feb 2 11:34:33 EST 2010


Feature Requests item #27767, was opened at 2010-02-02 16:34
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=578&aid=27767&group_id=126

Category: other
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: feature request: don't load plugins of outdated gems

Initial Comment:
Currently if you have several versions of a gem, its plugins might be loaded multiple times, even if there are bugs.  This makes it hard to change functionality in a plugin.
Request: only load them from the most recent versions of installed gem.
Thanks.
-r

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=578&aid=27767&group_id=126


More information about the Rubygems-developers mailing list