[Rubygems-developers] [ rubygems-Bugs-28744 ] setup.rb fails on 1.9.2

noreply at rubyforge.org noreply at rubyforge.org
Fri Dec 31 20:34:52 EST 2010


Bugs item #28744, was opened at 2010-11-22 22:38
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28744&group_id=126

Category: RubyGems installer (setup.rb)
Group: next
>Status: Closed
>Resolution: Rejected
Priority: 3
Submitted By: Erik Hollensbe (erikh)
Assigned to: Nobody (None)
Summary: setup.rb fails on 1.9.2

Initial Comment:
https://gist.github.com/190251852fbe20370543

This is the error as found as late as commit 81cd69180a067d638d10cd88099015e3408a5ec0.

The problem is that rubygems cannibalizes on its own setup_command for setup.rb, which in turn gets required by gem_prelude and this error shows up. Something along these lines will massage it through, but then all gem commands fail once it's installed:

https://gist.github.com/b74973ec7a7418655797

If you dig further you'll find that any attempt for rubygems/custom_require, as provided by prelude, will raise this issue. Overriding it with lib/rubygems/custom_require was something I tried, and didn't get very far. Maybe some of you guys with more domain knowledge can help.

I can provide a full image of my patches (which are not pretty and may incite anger, rage, and politics, as they almost completely eliminate prelude from being useful) if so desired, as once down this rabbit hole there be dragons.

Thanks,

-Erik

----------------------------------------------------------------------

>Comment By: Luis Lavena (luislavena)
Date: 2010-12-31 22:34

Message:
Hello,

Closing this out as the issue is inside Ruby's gem-prelude and can't be fixed in standalone RubyGems.

We are pretty aware of this issue but there is no easy solution.

Manual installation of RubyGems on top of Ruby 1.9.x is discouraged until that issue is solved in Ruby.


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=28744&group_id=126


More information about the Rubygems-developers mailing list