[Rubygems-developers] The 1.4 plan

Ryan Davis ryand-ruby at zenspider.com
Thu Dec 30 15:03:08 EST 2010


On Dec 30, 2010, at 04:44 , Luis Lavena wrote:

> Over here too, not even ruby -Ilib bin/gem works
> 
> since rubygems-update will be released, Users using 1.9.2 will be able
> to do "gem update --system" and bork their installations.
> 
> I'm looking into the 1.9 branch for the changes and see what can be merged.
> 
> I don't think 1.4.0 should go out without 1.9 compatibility.

Sorry, but unless compelling evidence comes in, I'm gonna override. All the 1.3s that shipped since 1.9 have had the same issue.

Nobody (afaik) has been able to _properly_ upgrade 1.9 since 1.9 shipped (there are hacky ways, but I'm talking about gem update --system). We're trying to address that in ruby-core, but with the current situation with the 1.9 prelude there is little we can do at this point.



More information about the Rubygems-developers mailing list