[Rubygems-developers] The 1.4 plan

Luis Lavena luislavena at gmail.com
Thu Dec 30 07:44:58 EST 2010

On Thu, Dec 30, 2010 at 9:41 AM, Erik Hollensbe <erik at hollensbe.org> wrote:
> On Dec 29, 2010, at 7:39 PM, Ryan Davis wrote:
>> I want to release what we have on the 1.4 branch. It needs some beatings. Can we get ppl to test against the 1.4 branch and report any errors to the list asap? Esp needed: windows, REE, linux.
> 1.8.7-p330 passes fine, but 1.9.2-p136 is causing some headaches:
> /home/ubuntu/rubygems/lib/rubygems/security.rb:688: warning: shadowing outer local variable - name
> /home/ubuntu/rubygems/lib/rubygems/remote_fetcher.rb:9:in `<class:RemoteFetcher>': uninitialized constant Gem::UserInteraction (NameError)

Over here too, not even ruby -Ilib bin/gem works

since rubygems-update will be released, Users using 1.9.2 will be able
to do "gem update --system" and bork their installations.

I'm looking into the 1.9 branch for the changes and see what can be merged.

I don't think 1.4.0 should go out without 1.9 compatibility.
Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Rubygems-developers mailing list