[Rubygems-developers] The 1.4 plan

Erik Hollensbe erik at hollensbe.org
Thu Dec 30 07:41:29 EST 2010


On Dec 29, 2010, at 7:39 PM, Ryan Davis wrote:
> I want to release what we have on the 1.4 branch. It needs some beatings. Can we get ppl to test against the 1.4 branch and report any errors to the list asap? Esp needed: windows, REE, linux.

1.8.7-p330 passes fine, but 1.9.2-p136 is causing some headaches:

/home/ubuntu/rubygems/lib/rubygems/security.rb:688: warning: shadowing outer local variable - name
/home/ubuntu/rubygems/lib/rubygems/remote_fetcher.rb:9:in `<class:RemoteFetcher>': uninitialized constant Gem::UserInteraction (NameError)
	from /home/ubuntu/rubygems/lib/rubygems/remote_fetcher.rb:7:in `<top (required)>'
	from /home/ubuntu/rubygems/lib/rubygems/custom_require.rb:29:in `require'
	from /home/ubuntu/rubygems/lib/rubygems/custom_require.rb:29:in `require'
	from /home/ubuntu/rubygems/lib/rubygems/test_utilities.rb:3:in `<top (required)>'
	from /home/ubuntu/rubygems/lib/rubygems/custom_require.rb:29:in `require'
	from /home/ubuntu/rubygems/lib/rubygems/custom_require.rb:29:in `require'
	from /home/ubuntu/rubygems/test/gemutilities.rb:15:in `<top (required)>'
	from /home/ubuntu/rubygems/lib/rubygems/custom_require.rb:29:in `require'
	from /home/ubuntu/rubygems/lib/rubygems/custom_require.rb:29:in `require'
	from /home/ubuntu/rubygems/test/test_gem_commands_query_command.rb:1:in `<top (required)>'
	from /home/ubuntu/rubygems/lib/rubygems/custom_require.rb:29:in `require'
	from /home/ubuntu/rubygems/lib/rubygems/custom_require.rb:29:in `require'
	from -e:1:in `<main>'
rake aborted!
Command failed with status (1): [/usr/local/rvm/rubies/ruby-1.9.2-p136/bin/...]

I'm not sure if this "matters" or not, but I figured it was worth mentioning.

-Erik


More information about the Rubygems-developers mailing list