[Rubygems-developers] The 1.4 plan

Ryan Davis ryand-ruby at zenspider.com
Thu Dec 30 00:24:41 EST 2010


On Dec 29, 2010, at 18:14 , Charles Oliver Nutter wrote:

> On Wed, Dec 29, 2010 at 6:39 PM, Ryan Davis <ryand-ruby at zenspider.com> wrote:
>> OK. I've cherry picked from master to 1.4 all but this commit:
> 
> I'll probably regret asking this, but...
> 
> Does that mean the plugin change has been merged to 1.4 also? Is this
> going against the 1.4/2.0 plan mentioned earlier?

It is going in 1.4. I haven't seen any credible evidence that it breaks anything significant, it has obvious benefit, and Eric's argument for 2.0 wasn't very strong since this isn't a backwards incompatible API change.

> I don't care one way or another, as long as the plugin change gets out
> there some day soon...

It'll go out in 2010 barring showstoppers we can't fix in time.




More information about the Rubygems-developers mailing list