[Rubygems-developers] The 1.4 plan

Ryan Davis ryand-ruby at zenspider.com
Wed Dec 29 19:39:34 EST 2010


On Dec 29, 2010, at 02:24 , Ryan Davis wrote:

> I've got a log-jam that looks like this:
> 
>> hoe is waiting for
>>  rubygems is waiting for
>>    rails is waiting for
>>      rack...
> 
> 
> there may be more that I don't know about.
> 
> According to Eric, the only reason why rubygems is held up by rails is because of raggi's work at removing or delaying requires. Apparently rails was dependent upon our require of thread and we'll break them if we release w/o it.
> 
> So to break this log jam I think I'm gonna add that one require back.

done and committed to master and merged to 1.4.

> This will let us release this month/year and we can take it right back out for a 1.5 release at the end of next month. The current diffs between master and 1.4 are ~700 lines and JB and Eric are reviewing them. That should be done today, I suspect.
> 
> I currently think we should merge master to 1.4 completely if we can and release by the end of the week.

OK. I've cherry picked from master to 1.4 all but this commit:

commit 183a2b6bae927eab8e32f476023bca00066e6aa7
Author: John Barnette <jbarnette at gmail.com>
Date:   Thu Dec 9 08:07:32 2010 -0800

    Remove deprecated Gem::Dependency#version_requirement methods.
    
    I'd be really surprised if this didn't break Rails 2.x. We'll sort it
    out during the prerelease cycle.

I want to release what we have on the 1.4 branch. It needs some beatings. Can we get ppl to test against the 1.4 branch and report any errors to the list asap? Esp needed: windows, REE, linux.



More information about the Rubygems-developers mailing list