[Rubygems-developers] The 1.4 plan

Ryan Davis ryand-ruby at zenspider.com
Wed Dec 29 05:24:05 EST 2010

I've got a log-jam that looks like this:

> hoe is waiting for
>   rubygems is waiting for
>     rails is waiting for
>       rack...

there may be more that I don't know about.

According to Eric, the only reason why rubygems is held up by rails is because of raggi's work at removing or delaying requires. Apparently rails was dependent upon our require of thread and we'll break them if we release w/o it.

So to break this log jam I think I'm gonna add that one require back.

This will let us release this month/year and we can take it right back out for a 1.5 release at the end of next month. The current diffs between master and 1.4 are ~700 lines and JB and Eric are reviewing them. That should be done today, I suspect.

I currently think we should merge master to 1.4 completely if we can and release by the end of the week.

This will let us focus on reconciling differences between ruby-core's branch (on the 1.9 branch) as it weighs in at a HEAVY 4720 lines 'o diff. We can get that merged back to ruby-core with our 1.5 release and then shut down that branch entirely.

More information about the Rubygems-developers mailing list