[Rubygems-developers] CI Status (was: RubyGemsGitHub build 1e71d86 failed)

Chad Woolley thewoolleyman at gmail.com
Tue Dec 14 01:52:45 EST 2010


On Mon, Dec 13, 2010 at 9:17 PM, Chad Woolley <thewoolleyman at gmail.com> wrote:
> I've got a working pass at a dynamic multi-interpreter build here (and
> it's green under 1.8.7):
>
> http://cibuilder.pivotallabs.com:3333/builds/RubyGems-1_8_7-p302
> https://github.com/thewoolleyman/rubygems/tree/cifixes
>
> However, I had to hardcode and duplicate the dev gem dependency
> installation because I don't know how to make Hoe not use sudo for
> "check_extra_deps"
>
> Ryan, is there a way to not use sudo for "check_extra_deps"?

Here's builds for 1.9.1 and 1.9.2 as well.  They seem to have some
problems, which should be fixed before I enable build status
notifications for them.  These builds should be locally reproducible
by invoking 'ci_build.sh <rvm interpreter>'.  Let me know if you think
the problems are related to environment or misconfiguration:

http://cibuilder.pivotallabs.com:3333/builds/RubyGems-1_9_1-p429
http://cibuilder.pivotallabs.com:3333/builds/RubyGems-1_9_2-rc2

Thx,
-- Chad


More information about the Rubygems-developers mailing list