[Rubygems-developers] [ rubygems-Patches-28083 ] Eliminate a misleading warning when installing a gem with the --bindir option

noreply at rubyforge.org noreply at rubyforge.org
Mon Apr 12 13:05:12 EDT 2010


Patches item #28083, was opened at 2010-04-12 19:05
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=577&aid=28083&group_id=126

Category: `gem install`
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Frank Luithle (sigi)
Assigned to: Nobody (None)
Summary: Eliminate a misleading warning when installing a gem with the --bindir option

Initial Comment:
The --bindir option changes the target directory for executables/wrappers.  'gem install' makes a sanity check to see if the bin target directory is in the current PATH, and outputs a warning if that's not the case.

However, when --bindir is used, the value of the option is not recognized when checking for PATH consistency, so the warning is always given even if the PATH is correct (ie. it contains the target bin directory).

This patch corrects this towards a more sane behaviour.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=577&aid=28083&group_id=126


More information about the Rubygems-developers mailing list